Services
Oracle Audit / Hardening
Security Training
Consulting

Information
Oracle Security Blog
Published AlertsRSS Published Alerts
Upcoming AlertsRSS Published Alerts
Patch Information
Whitepaper
Presentations
Oracle Fact Sheets
Exploits
Tutorials
Videos
Scripts

News & Events
Events
News

Company
Contact
People
Partner
Impressum
Sitemap


Search



Search Red-Database-Security
SQL Injection in package SYS.DBMS_METADATA_UTIL

Name SQL Injection in package SYS.DBMS_METADATA_UTIL
Systems Affected Oracle Database
Severity High Risk
Category SQL Injection (DB05)
Vendor URL http://www.oracle.com/
Author Alexander Kornbrust (ak at red-database-security.com)
Advisory 17 Jan 2006 (V 1.00)


Details
The package SYS.DBMS_METADATA_UTIL contains 4 SQL injection vulnerabilities in the functions LONG2VARCHAR, LONG2VCMAX, LONG2VCNT, LONG2CLOB. Oracle fixed these vulnerabilities with the package dbms_assert.


Package

Function/Procedure

Vulnerability / Change

DBMS_METADATA_UTIL LONG2VARCHAR Parameter col, tab vulnerable against SQL Injection
DBMS_METADATA_UTIL LONG2VCMAX Parameter col, tab vulnerable against SQL Injection
DBMS_METADATA_UTIL LONG2VCNT Parameter col, tab vulnerable against SQL Injection
DBMS_METADATA_UTIL LONG2CLOB Parameter col, tab vulnerable against SQL Injection



Patch Information
Apply the patches for Oracle CPU Jan 2006 on top of Oracle 10g Release 1.

[metalink.oracle.com]

History
01-nov-2005 Oracle secalert was informed
02-nov-2005 Oracle secalert asked for an exploit
17-jan-2006 Oracle published CPU January 2006
17-jan-2006 Advisory published
19-jan-2006 Oracle Vuln# DB05 added


2006 by Red-Database-Security GmbH - last update 19-jan-2006